Google Maps API error

22nd of July Google announced some significant changes in usage of Google Maps. All websites (except localhost and websites created prior to 22.06.2016) that use Google Maps now require a Google Maps API key. Here you can read the full statement by Google.

How to get my API key?

A full tutorial on how to obtain an API key is described in official Google documentation here: https://developers.google.com/maps/documentation/javascript/get-api-key

In your, Google Cloud Platform navigate to APIs & Services to find your Credentials. The new API key can be created after clicking on the button “Create credentials”, the selection offers you the option “API Key”.

We strongly recommend you pay attention to restrictions. You should restrict your API key using HTTP Referrers only for your websites that will use the Google Maps API key. This way no one else can steal and use your API key.

Which APIs do I need?

Because Google doesn’t explain clearly which APIs do you need to activate, here is the list of required APIs for all Google Maps features:

  • Google Maps Directions
  • Google Maps Distance Matrix
  • Google Maps Elevation
  • Google Maps Geocoding
  • Google Maps JavaScript

You have to enable these APIs in the Library section.

Where to insert my API key?

If you login to your WordPress as an administrator, you can insert an API key in Citadela Listing > Integrations:

Leave a Reply

Your email address will not be published. Required fields are marked *